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1.1. What is PSCAD Initializer 

An Electro Magnetic Transient (EMT) program such as PSCAD simulates a behaviour of a power system 
network after a disturbance, such as fault or circuit breaker operation. During this short period, the 
system gradually changes from one steady state behaviour to another.  

The purpose of the PSCAD Initializer is to set up the proper power flow conditions (e.g. correct voltage 
and angles at buses, active, reactive power flows between buses, etc.) prior to the disturbance. This 
involves solution to the power flow equations and setting up the correct parameters of generators, 
sources in PSCAD, etc. 
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1.2. How to Setup the PSCAD Initializer 

• Install and open “PSCAD Initializer“ through MyUpdater utility (https://mycentre.hvdc.ca/). 

• Select the power flow engine (go to Simulation > Compilers) to be used for the load flow 
solution. 

The purpose of the power flow engine is to solve the power flow of the network as required 
by the PSCAD Initializer. The Power Flow Light is the default power flow solver developed by 
Manitoba Hydro International. Alternatively SIEMENS PSS®E software is also supported. 

• Select the Compiler Settings (go to Simulation > Compiler Settings)  and set the path for the 
PowerFlow executable  

(e.g. Path to PSCAD Power Flow Light executable  C:\....\ PFlightv0_1_4.exe  or path to  
PSS®E executable  C:\... \PTI\PSSE33\PSSBIN\pssecmd33.exe) 
 
Note that in case of PSS®E engine, the command-line executable should be selected (e.g. 
pssecmd*.exe).  For further details of Compiler Settings, see Power flow engine parameter 
settings. 
 

  

https://mycentre.hvdc.ca/
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1.3. Illustrative Example: Initialization of the IEEE 14 Bus System Example 

• Open the example IEEE14BUS_NOT_INITIALIZED.pscx PSCAD case in PSCAD software and 
run the case. As Initializer requires the transmission line solutions, the un-initialized PSCAD 
case should be ‘Build or Run’ before the initializer tool can extract necessary network data 
from the PSCAD case. The ‘uninitialized’ case will not converge to the expected power flow 
conditions. 

o For example, the generator at bus BU_BUS_2, is set to generate 40 MW of active 
power and the bus voltage to be controlled to 144.21 kV. However, the measured 
active power and voltage do not match the expected values (see Figure 1).  

 

Figure 1 - Generator at B2 BUS 2 

 
 

• The PSCAD initializer tool can be used to properly initialize the PSCAD case and once 
initialized, the simulation will converge to the expected network steady state power flow 
conditions. The steps involved are the following. 
 

o Open “PSCAD Initializer“ through MyUpdater utility. 

o Open the PSCAD example case (File > Open and select the PSCAD case 
“IEEE14BUS_NOT_INITIALIZED.pscx”).  
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Figure 2 - IEEE 14 bus system in the PSCAD Initializer 

 
o Double-click on the main canvas (or double-click on any bus). This will open a new 

window (see Figure 3).  From the list of buses, select the bus that you want to set as 
a swing bus/slack (there should be a voltage source associated with the swing bus to 
supply required active and reactive power, e.g. bus B6_BUS_6).  Change the ‘Type of 
Bus’ to ‘Swing bus’ (by default all buses are defined as Auto Detect).  

 

Figure 3 - Bus details and additional parameters windows 
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o Optional: Set additional load flow parameters, if required (see section 1.7 for more 
details). 

o Run the case (Simulation > Run) and check if load flow is properly converged and 
solved from the output window (bottom left) as shown in Figure 4.   

 

Figure 4 - Power flow solution 

 
 

o Save the case. You may want to give a diffent name to PSCAD case to preserve the 
settings in the original case (e.g. “IEEE14BUS_ INITIALIZED.pscx”). 

o Open the saved PSCAD case (PSCAIEEE14BUS_INITIALIZED.pscx) in PSCAD and run 
the case. Verify the steady state values, such as bus voltages, active and reactive 
power flow through branches. The active power and voltages are as expected as 
shown in Figure 5. 
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Figure 5 - Bus B2_BUS_2 in solved PSCAD case 
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1.4. How Initializer works 

The initializer generates a power flow network data file (“input.netdata”) from a PSCAD case. The 
“input.netdata” is solved by a power flow engine and generates an output data file “output.netdata.” 
The Initializer uses the information in the solved “output.netdata” file to update necessray fields of the 
PSCAD case (see Figure 6). 

 

Figure 6 - Initializer block diagram 

 

 

  

PSCAD Un-initialized CASE 

Generate unsolved raw data file 
(input.raw) 

Solve raw data file (output.raw) 

Update PSCAD case with solved 
raw file data 
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1.5. Power Flow Solution 

The objective of power flow solution is to determine bus voltages and angles, active and reactive power 
through branches, generator and loads for steady state condition. This is a constrained optimization 
problem.   

There are four variables associated with each bus: 

• Voltage |V| 

• Phase angle |δ| 

• Active or real power |P| 

• Reactive power |Q| 

 P Q V δ 

P-Q bus known known unknown unknown 

P-V bus known unknown known unknown 

Slack bus/swing bus unknown unknown known known 

 

The power flow solution calculates the P, Q for swing/slack bus, Q, δ for PV buses and V, δ for PQ buses.  
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1.6. Power Flow Engine Parameter Settings  

The Power flow engine parameers are shown in Figure 7 and described in Table 1. 

 

Figure 7 - Initializer settings dialog 
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Option Value Description 
Compile folder $(OutputDir) 

This macro is the default location for 
output files. 
The default macro resolves to: 
FilePath\CaseName.init 
e.g. 
C:\Folder\Case.pscx 
Has a $(OutputDir) 
C:\Folder\Case.init\ 

This option provides the location for 
all temporary files that are generated 
when compiling. 

Overwrite input file Logical 
(True or False) 

The “input.raw” is the unsolved load 
flow file created from the PSCAD 
case. If True, the “input.raw” data file 
is updated with load flow solved 
data, otherwise it is written to a new 
file “output.raw”. False is 
recommended as the two files 
(before and after solution) can be 
compared manually if needed. 

PowerFlow Executable (a) PSCAD power flow light engine 
e.g. C:\....\ PFlightv0_1_4.exe  

or  

(b) PSSE engine usually located in  
C:\Program Files 
(x86)\PTI\PSSE##\PSSBIN\pssecmd##.exe 

e.g. 
C:\Program Files 
(x86)\PTI\PSSE33\PSSBIN\pssecmd33.exe 

Path to power flow solution engine. 
In case of PSSE engine, the 
command-line execute should be 
selected (e.g. pssecmd*.exe).   

Solution Options   

Acceleration Factor Real  Acceleration Factor for power flow 
solution algorithm 

Flat Start Logical 
(True or False) 

If True, the bus voltages are set to 1.0 
and angle to 0.0 as initial condition 
for power follow solution. If False, 
previous power flow values are used 
as seed values. 

Power Flow solution tolerance Real This is Power Flow convergence 
tolerance 

Q iteration Real Maximum number of iterations for 
relative power limits 

Reactive Power Limits Choice  
(Ignore/Iterations/Auto) 

This is how to treat reactive power 
limits. If “ignore”, reactive power 
limits are neglected. 

The Number of Iterations Integer Maximum number of iterations for 
convergence 

Zero Impedance Threshold Real This is the tolerance/threshold to 
identify zero impedance lines 

 
Table 1: Power flow parameter settings 
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1.7. Additional Initializer Component Parameters  

The Initializer uses relevant parameters of PSCAD master library components for initialization. However 
in some components, additional parameters may be required to define. These parameters can be seen 
from the extended properties window in the Initializer.  

• Bus parameters 
 

Select the bus to see the bus parameters. 

 

Figure 8 - List of buses in the network 

 

Figure 9 - Bus parameters 
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Base Voltage Real Bus base voltage in kV.  The default value is base kV of 
the PSCAD Bus component.  

Bus Number Integer Define unique bus number 

If the bus number is -1, Initializer will automatically 
specify the bus number  

Bus Type Choice Select the Bus type from following options 

• Auto Detect 

• Swing bus (or Swing bus) 

• Generator bus (or PV bus) 

• Non-generator bus (or PQ bus) 

• isolated bus (bus is disconnected) 

If Auto Detect is selected, Initializer will automatically 
select the bus type, however the Swing bus should be 
manually selected. There is at least one Swing bus in the 
system.  

Phase Angle Real This displays the phase angle of the bus in degrees after 
the load flow solution 

Voltage Real This displays the voltage magnitude of the bus in 
degrees after the load flow solution  

 

Table 2: Bus parameters 
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• Generator extended parameters 

Select the voltage source to see generator parameters: 

 

Figure 10 - List of sources 

 

The generator/source extended parameters are shown below: 

IsQset_2 Text True or false 

If True, the Generator reactive 
power limits are enforced.  

Qmax Real Maximum Reactive power in MVar 

Qmin Real Minimum Reactive power in Mvar 

RmtBus Integer The bus number of the Regulated 
Bus. If left as 0 the Generator will 
regulate its own bus. 

0 By Default 

 

The load extended parameters are shown below: 

IsLdMdl Text True or false 

If true, the load will be modeled as 
a standard load 

If false, the load will be modeled as 
a fixed shunt 
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1.8. Setting up PSCAD Case for Initialization 

• Voltage sources to represent generator  
 

Three Phase Voltage Source Model 2 

 The “Three phase voltage source Model 2” represents a generator in the initialization procedure. In the 
“Signal Parameters” section of the voltage source, the specified parameters are set as “At the terminal.” 
The power flow parameters are defined in the “Terminal conditions” section. 

Three Phase Voltage Source Model 1 

The “Three phase voltage source Model 1” also represents a generator (or network equivalent). 

In the “Configuration” section, set “Source Control” to “Fixed” and ”Specified parameters” to “At the 
terminal.”  The power flow parameters can be found in “Source Values for Fixed Control” section. 
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1.9. Modelling Guidelines and Limitations  

• If a load is represented using passive elements, such as R,L,C, the load should be replaced 
with PSCAD load components. Note that R,L,C are considered as ac lines. 

• Transmission lines with multiple circuits are not supported.   

• Transmission lines or cables with more than three conductors are not supported. (e.g. cable 
with sheath, etc.). Alternatively, these models can be put inside a page module and 
modelled as an AC or DC line (see section 1.10 for details). 

• Breakers are not supported.  

• PSCAD calculates certain parameters at time zero or in the first few time steps to be used 
for the rest of the time domain simulation.  This pre-processing data is not available to the 
Initializer.  Some parameters are defined externally as signals to the module or the 
components (e.g.  a value of the tap changer externally connected to  the transformer, 
signal inputs to the page modules in PSCAD). 

• Some master library components may not be supported.  Resister, inductor, capacitor, 
three-phase two winding or three-winding transformers (auto transformers not supported), 
all three-phase sources, transmission lines models, and coupled pi-circuit are supported. 

• PSCAD cases linked with Parallel Network Interface (PNI)  are not supported. 
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1.10. Dynamic Component Modelling  

Dynamic componets, such as STATCOM, generators, and windfarms defined in  page modules, can be 
initialized. However this requires some additional steps.  

First, the power flow equivalent model to represent the PSCAD dynamic component is identified (e.g. 
Generator , FACTS, dc lines, etc.). Then the relevant power flow parameters are defined in the PSCAD 
page module. In the Initializer, the page module is identified as the relevant power flow equivalent 
model and finally the relationship is established between the parameters of power flow equivalent 
model to the parameters of the PSCAD page module. 

This is demostrated using an example involving a page module contaning a generator component with 
exciters, governeor, etc.  This module is connected to Bus 4, as shown in Figure 11. 

In this initialization process, the generator set voltage magnitude and active power is defined. The 
objective is to find the voltage magnitude and angle of the connected bus and reactive power of the 
generator from the Initializer tool. These values can be used to set initialization parameters of PSCAD 
generator model.  

 

Figure 11 - PSCAD main page 

 

Figure 12 - Generator details inside page module of Sync 
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a. Set up PSCAD case for initialization. 

In the parameter section of the page module, the initialization parameters (i.e. terminal 
reactive power (I_Q0), terminal voltage phase (I_Pheta) and terminal voltage 
magnitude(I_VT)) are created as shown below:  

 

Figure 13 - Parameters for initialization 

In the synchronous machine, these parameters can be linked to the appropriate entries for 
initialization.  

 

 

Figure 14 - Synchronous machine model parameters 
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b. Load the case in to the Initializer and define Bus 4 as a generator bus.  

 

Figure 15 - Bus parameters of the Initializer 

 

 

Double click on the generator page module (Sync) and resolve it as a Generator. 

 

Figure 16 - Resolve Schematic in the Initializer 
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The generator initialization parameter are shown below. 

 

Figure 17 - Generator parameters for the Initializer 

 

 

The generator parameters used for power flow solution is set in the properties section. 

Parameter Corresponding power flow parameter Value 

Active power (MW) Generator active power output (MW) 240 

Voltage magnitude (pu) Regulated voltage setpoint (VS) 1.03 
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In the Output section, the link between PSCAD parameters and the power flow parameters 
is established. 

Power flow parameter Description Corresponding PSCAD 
generator parameters 

Reactive power parameter Generator reactive power output (QG) I_Q0 

Phase angle parameter  Angle of bus 4 (VA) I_Pheta 

Voltage parameter  voltage magnitude of Bus 4 (VM) I_VT 

 

The units of PSCAD generator parameters are defined. 

Parameter PSCAD generator parameters units 

Reactive power unit MVAR 

Phase angle unit rad 

Voltage unit pu 

 

 

The unit conversion from power flow parameter to PSCAD generator parameter is defined 
as shown below. 

Note 

#(value) means power flow parameter value.  

Conversion PSCAD Parameter 
Units 

Power flow parameter units Conversion from power 
flow parameters to PSCAD 

parameters 

Reactive power equation Mvar Mvar Not required 

Phase angle equation rad Degrees 0.0174533 

Voltage equation pu pu ? 

 

The case can now be initialized using Initializer tool.  
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